Latest Magento Patch – SUPEE-6285

You probably already know this if you’re someone who spends any time in the Magento Admin section, but there’s a new patch with a serious enough warning to install straight away. If you’re a eCommerce store owner who doesn’t spend any time in Magento Admin, then ask someone who does whether they’ve seen or dealt … Read more…

Paypal, Poodle and SSLv3 for Magento hosting customers

The latest in the recent spate of “security scares” (Heartbleed, Shellshock, et. al.) is upon us, The SSL3 Poodle! The non-tech summary is “SSL3 is an older, weaker method of encryption, and is vulnerable. Most modern secure connections should use a newer method called TLS”. So in this post, Poodle SSL 3.0 Vulnerability, by Joe Nash for … Read more…